Database corruption


Yup.

So yesterday morning a few people reported issues with JDMST not loading right. I failed to see any problems, but after some trial and error I noticed an advertising banner was screwing up the entire forum, at this point I’d already ripped a lot of hair out and attempted to rebuilt and optimise tables in the backend. Unfortunately for me something crapped out when rebuilding some tables… fair call as JDMST is a MASSIVE forum, this in turn totally destroyed something. People were not able to see new posts, some couldn’t make posts… nightmare.

I googled hard, and harder, no luck. I ended up contacting some developer friends, no luck there either (they were all too busy). I contacted the host in the USA and they suggested I revert to a previously backed up snapshot of the forum. Problem is the backup was 4 days old. I did it, as it had to be done, but all posts made in the past 4 days were lost, all private messages too and this has obviously upset a fair few people (members and traders as well).

On the one hand I’m glad everything is working as it should again. Daily backups could be worth the extra $$$ perhaps, but then again it’s not the kind of thing that happens a lot (and it was my fault in the first place!).

This entry was posted in Uncategorised. Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>